cancel
Showing results for 
Search instead for 
Did you mean: 

How to Migrate Alfresco in Windows to Linux CentOS?

etzapata
Champ in-the-making
Champ in-the-making
Hello everyone,

We are running Alfresco under:
Windows Server 2003
JBOSS with Alfresco version 1.4
MySQL5
jdk-1_5_0_09-windows-i586

We are planning this week to migrate everything to:

Linux CentOS5
Apache Tomcat 5
MySQL5

How do we start the migration?

My first attempt to mount the hard disk (alf_data) from Windows is not recognized by CentOS.
Any input is highly appreciated.

EriCtZ
18 REPLIES 18

rivetlogic
Champ on-the-rise
Champ on-the-rise
Hi,

Take a look at this Wiki page. You could do a  full export and import them at bootstrap.

http://wiki.alfresco.com/wiki/Export_and_Import.


Regards,
Shagul

alexander
Champ in-the-making
Champ in-the-making
My experience with Export / Import is that it can take very long and even fail with large installations.

If this is a case you can  move database by MySQL export / import and copy content store to relevant directories. You may need to re-build indexes (look for index recovery=FULL in the properties).

norgan
Champ in-the-making
Champ in-the-making
Hello Alexander,
i have had the experience, that your approach is not quite free from problems. I had the following situation with this full movement - is this maybe an index problem as well ?

1) two cloned VMs with 2.9b + Openoffice 2.4
2) Connection between Alfresco & OO breaks on second VM
3) clone first VM again, connection OO - Alfresco works fine
4) make a full MySQL Backup and copy backup.sql + alf_data files to third VM
5) After restoring MySQl und alf_data, the connection was broken again. (Cant find RMI interface or somtheing like that)

Regards, Norgan

alexander
Champ in-the-making
Champ in-the-making
Norgan

RMI interface error is often from wrong hostname and /etc/hosts entry.

norgan
Champ in-the-making
Champ in-the-making
Hello Alexander,
Norgan

RMI interface error is often from wrong hostname and /etc/hosts entry.

thanks, but unfortunately I fought with that before and do know that. Thats why I took the approach of cloning the working VM and restoring the content. The new VM worked fine until I restored mysql-db and alf_data, afterwards it was broken! And even in linux, the hostname and /etc/hosts are not stored in alfresco repository 😉 So there must be some other setting, which is stored either in the mysql or in the alf_data structure.

Regards, Norgan

sacco
Champ in-the-making
Champ in-the-making
Hello everyone,
We are planning this week to migrate everything to:

You don't give the version of Alfresco in use, but be careful to choose a version
of Alfresco to perform the export (yes, you may need to upgrade to a beta or
nightly build for this to work).  In particular, do not attempt this with
the standard distribution version 2.1 : in my experience it normally completely
fails to import (even back into the same version), and when it apparently
succeeds there can be (fatal and irresolvable) problems with the repository later.

Unfortunately, Alfresco have not made any general release to fix this serious problem.

etzapata
Champ in-the-making
Champ in-the-making
Hi Sacco,

Thank you very for the tips. Yes, I forgot to mention that we will be upgrading Alfresco version as well (from 1.4 to 2.1). What I did was:

1.  Copy the Alf_data from Windows platform (separate harddisk);
2.  Backup the database (MySQL5) in Windows then restore in Linux CentOS5
3.  Copy all my configurations in alfresco1.4 windows to the extension directory of alfresco 2.1 linux. (There are also config that I did directly with the alfresco.war file)

The Alf_data from windows ntfs has been copied to linux ext3 but the restore of the database fails (it says: "Error: Unknown object in backup file").

How should I do it in the right way?

Thank you very much for any tips you could share.

EriCtZ

etzapata
Champ in-the-making
Champ in-the-making
Hi all,

The error "Error: Unknown object in backup file" was due to the gui cannot process large database file. I tried using command line and it was successfully restored but I have now new problem: Schema update failed.

Is there anyone knew how to solve this error? We are planning to re-upload the whole alf_data in production server (windows2003) if we cannot make this work but I understand that this would take days to reupload (via ftp).

Hope someone out there can give us a user friendly advise and tips.
Thank you very much.

EriCtZ

etzapata
Champ in-the-making
Champ in-the-making
Hi All,

Has anyone successfully did this or nobody has tried doing what we are doing? But is this possible:?

Migrating from Alfresco v1.4 in windows-jboss to Alfresco v2.1 in linux-tomcat
Database Mysql is the same.

Please help.

EriCtZ