cancel
Showing results for 
Search instead for 
Did you mean: 

Serious error when attempting to create a user

darrenh65
Champ in-the-making
Champ in-the-making
Hi,
I have run into a problem when attempting to create a new user. I have reinstalled alfresco a number of times and I believe the sequence to create the error to be as follows:

1. login as admin
2. go to admin console
3. create a user.

(this will work ok, it is a test to make sure all is working)

4. go to 'Compnay Home' space
5. view details
6. modify the name of the space to anything else. We used our own orgainisation name.
7. save it
8. logout

(error does not occur until you log out)

9. login again as admin
10. attempt to create another user.

The system fails with the following messages:

javax.faces.el.EvaluationException: Exception while invoking expression #{NewUserWizard.startWizard}

caused by:
java.lang.IllegalStateException: Unable to find company home space path: app:company_home

Hide Details

javax.faces.el.EvaluationException: Exception while invoking expression #{NewUserWizard.startWizard} at org.apache.myfaces.el.MethodBindingImpl.invoke(MethodBindingImpl.java:153) at javax.faces.component.UICommand.broadcast(UICommand.java:86) at javax.faces.component.UIViewRoot._broadcastForPhase(UIViewRoot.java:90) at javax.faces.component.UIViewRoot.processApplication(UIViewRoot.java:164) at org.apache.myfaces.lifecycle.LifecycleImpl.invokeApplication(LifecycleImpl.java:271) at org.apache.myfaces.lifecycle.LifecycleImpl.execute(LifecycleImpl.java:86) at javax.faces.webapp.FacesServlet.service(FacesServlet.java:94) at org.alfresco.web.app.servlet.AlfrescoFacesServlet.service(AlfrescoFacesServlet.java:49) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173) at org.alfresco.web.app.servlet.ModeDetectionFilter.doFilter(ModeDetectionFilter.java:59) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173) at org.alfresco.web.app.servlet.AuthenticationFilter.doFilter(AuthenticationFilter.java:70) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173) at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213) at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178) at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126) at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105) at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107) at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148) at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:868) at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:663) at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527) at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80) at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684) at java.lang.Thread.run(Thread.java:595) Caused by: java.lang.IllegalStateException: Unable to find company home space path: app:company_home at org.alfresco.web.bean.wizard.NewUserWizard.getCompanyHomeSpace(NewUserWizard.java:860) at org.alfresco.web.bean.wizard.NewUserWizard.init(NewUserWizard.java:178) at org.alfresco.web.bean.wizard.AbstractWizardBean.startWizard(AbstractWizardBean.java:114) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:585) at org.apache.myfaces.el.MethodBindingImpl.invoke(MethodBindingImpl.java:129) … 27 more

We are using:
Alfresco v1.1 on our own Tomcat test server v5.5.12 with java v1.5.0_05-b05.
Server is Fedora Core 2 with kernel v2.6.10-1.770_FC2smp

Has anyone else seen this?
Comments appreciated

Darren
4 REPLIES 4

andy
Champ on-the-rise
Champ on-the-rise
Hi

I have had a quick look here.
It is a bug after changing to use the service for files and folders.


You can not rename the company home in release 1.1.
It has a side effect of changing the path to the node, which is currently used to identify the company home space node.

See issue AR-318

Regards

Andy

darrenh65
Champ in-the-making
Champ in-the-making
Thanks Andy,
I'll leave the name alone for now and keep an eye on AR-318.
Keep up the great work. This product has enormous potential!

lgr
Champ in-the-making
Champ in-the-making
Hi,

Just for your information, i use another language, i've renamed the company home in my messages/bootstrap-spaces_fr_FR.properties (but i've leaved company name as default in messages/bootstrap-spaces.properties), and user creation works well.

I haven't renamed the default space using the GUI, but directly by editing message/bootstrap-spaces_fr_FR.properties. This is under linux, with the tomcat release.

Laurent.

davidc
Star Contributor
Star Contributor
A fix has been made to allow Company Home rename and will be available in v1.1.1 coming soon (or nightly build, or svn).