<?xml version="1.0" encoding="UTF-8"?>
<rss xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns:taxo="http://purl.org/rss/1.0/modules/taxonomy/" version="2.0">
  <channel>
    <title>topic Ubuntu Dapper Server Installation Error in Alfresco Archive</title>
    <link>https://connect.hyland.com/t5/alfresco-archive/ubuntu-dapper-server-installation-error/m-p/77533#M51306</link>
    <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;SPAN&gt;When attempting to install the Alfresco binary, AlfrescoCommunity-1.4-Linux-x86-Install, I receive the error: "./AlfrescoCommunity-1.4-Linux-x86-Install: error while loading shared libraries: libX11.so.6: cannot open shared object file: No such file or directory".&amp;nbsp; I tried to perform some research regarding the libX11.so.6; however, I cannot find any leads.&amp;nbsp; I am currently using Ubuntu Dapper &lt;/SPAN&gt;&lt;SPAN style="text-decoration: underline;"&gt;Server&lt;/SPAN&gt;&lt;SPAN&gt;, no GUI.&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;Thank you for any help.&amp;nbsp; Do I need to install a GUI?&lt;/SPAN&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
    <pubDate>Fri, 23 Feb 2007 02:35:22 GMT</pubDate>
    <dc:creator>mwarndt</dc:creator>
    <dc:date>2007-02-23T02:35:22Z</dc:date>
    <item>
      <title>Ubuntu Dapper Server Installation Error</title>
      <link>https://connect.hyland.com/t5/alfresco-archive/ubuntu-dapper-server-installation-error/m-p/77533#M51306</link>
      <description>When attempting to install the Alfresco binary, AlfrescoCommunity-1.4-Linux-x86-Install, I receive the error: "./AlfrescoCommunity-1.4-Linux-x86-Install: error while loading shared libraries: libX11.so.6: cannot open shared object file: No such file or directory".&amp;nbsp; I tried to perform some research r</description>
      <pubDate>Fri, 23 Feb 2007 02:35:22 GMT</pubDate>
      <guid>https://connect.hyland.com/t5/alfresco-archive/ubuntu-dapper-server-installation-error/m-p/77533#M51306</guid>
      <dc:creator>mwarndt</dc:creator>
      <dc:date>2007-02-23T02:35:22Z</dc:date>
    </item>
    <item>
      <title>Re: Ubuntu Dapper Server Installation Error</title>
      <link>https://connect.hyland.com/t5/alfresco-archive/ubuntu-dapper-server-installation-error/m-p/77534#M51307</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;SPAN&gt;I have used the AlfrescoCOmmunity-1.4-linux-x86-install it does give you a gui wizard-like install. I don't know that there are any options for running the install without a gui. You might have to take the long way, and install sun-java5-jdk, plus tomcat5.5 or jboss, and a database like mysql, and if you want the awesome document conversion capabilities, openoffice. Of course than you download the alfresco.war file and copy it to the right place.&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;I have found many oddities while installing on edgy. I don't know if you will run into the same problems, but watch out for these:&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;If you do a standalone tomcat5.5, the security settings do not let alfresco launch. I cheated and modified the /etc/default/tomcat5.5 to turn off security (although this is not recommended) for testing. The recommended method would have you add permissions to one of the files in /etc/tomcat5/policy.d. I tried to do this, figuring out, one by one, what permissions alfresco needed by reading the errors in the log files. After a half hour of that silliness, it went out the window.&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;I also had to manually set the JAVA_HOME settings in the same file to point to the directory for java. ( I can't recall the directory , but the docs for sun-java5-jdk or sun-java5-jre has info on it. There should be a file named JAVA_HOME in /usr/share/docs/sun-java5-jre or jdk. Just cat the file to read it.) I did not have to do this in Debian etch.&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;Also, the standalone tomcat on ubuntu edgy and other debain based distros launches on port 8180 instead of 8080 like on less sexy distros.&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;for image conversion you will have to install imagemagick. Once installed, in /usr/bin you need to create a symbolic link for convert to imconvert by issuing the command&lt;/SPAN&gt;&lt;BR /&gt;&lt;SPAN&gt;ln -s convert imconvert&lt;/SPAN&gt;&lt;BR /&gt;&lt;SPAN&gt;(make sure this is in /usr/bin)&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;If you use standalone tomcat, you will find that it launches at startup while you have to manually start openoffice with a script or on the command line. This is a major pain as described below. I actually gave up on using the alfresco.war with a standalone tomcat for a while.&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;The document conversions just would not work if openoffice is launched after tomcat, and/or with a different user.So I cheated again and edited the init file for tomcat5 and changed the TOMCAT_USER to root. The file is at /etc/init.d/tomcat5 - Again I don't know how secure this is, but I needed it to work. You might be more clever.&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;I copied the script from one of the other bundles for alfresco to launch openoffice as a daemon. For now I manually launch the start_oo.sh script then wait for 10 seconds and manually start tomcat by doing /etc/init.d/tomcat5 start as root. If you do not stop tomcat from launching at system startup, you might have to stop tomcat first, then restart it.&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;This all seems to work fine on Debian etch and Ubuntu 6.10 Desktop. I could not get the document conversion feature to work on dapper LTS.&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;I will mention for the sake of not shutting up, that I had done so much testing with alfresco and mysql, that when I reinstalled alfresco/tomcat and used mysql, alf would not start. I had to remove the old alfresco database in mysql and recreate it using the instructions provided. I also modified the database creation file that alfresco offers to make sure that the alfresco database is created in utf8. To the file db_setup.sql, on the line "create database alfresco;", I added "default character set utf8" before the closing ;.&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;There are other small details to watch our for. If anyone is interested in more, just post a comment here and I will try to help.&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;Hopes this helps someone.&lt;/SPAN&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Sat, 24 Feb 2007 00:18:25 GMT</pubDate>
      <guid>https://connect.hyland.com/t5/alfresco-archive/ubuntu-dapper-server-installation-error/m-p/77534#M51307</guid>
      <dc:creator>heckle</dc:creator>
      <dc:date>2007-02-24T00:18:25Z</dc:date>
    </item>
  </channel>
</rss>

