<?xml version="1.0" encoding="UTF-8"?>
<rss xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns:taxo="http://purl.org/rss/1.0/modules/taxonomy/" version="2.0">
  <channel>
    <title>topic Unable to view process definitions via probe: SAXParseExcept in Alfresco Archive</title>
    <link>https://connect.hyland.com/t5/alfresco-archive/unable-to-view-process-definitions-via-probe-saxparseexcept/m-p/77413#M51196</link>
    <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;SPAN&gt;Folks-&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;&amp;nbsp; I'm using activiti 5.6, via the grails activiti plugin, without a problem. Process definitions are deployed correctly, and can view them correctly via the activiti RepositoryService class. But I get into a problem when I start up the activiti-probe and activiti-explorer webapplication. Attempts to view deployed processes in either causes the following exception in the server logs:&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;Caused by: org.xml.sax.SAXParseException: Content is not allowed in prolog.&lt;/SPAN&gt;&lt;BR /&gt;&lt;SPAN&gt;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)&lt;/SPAN&gt;&lt;BR /&gt;&lt;SPAN&gt;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)&lt;/SPAN&gt;&lt;BR /&gt;&lt;SPAN&gt;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; at org.apache.xerces.jaxp.SAXParserImpl.parse(Unknown Source)&lt;/SPAN&gt;&lt;BR /&gt;&lt;SPAN&gt;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; at javax.xml.parsers.SAXParser.parse(SAXParser.java:198)&lt;/SPAN&gt;&lt;BR /&gt;&lt;SPAN&gt;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; at org.activiti.engine.impl.util.xml.Parse.execute(Parse.java:133)&lt;/SPAN&gt;&lt;BR /&gt;&lt;SPAN&gt;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; … 31 more&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;The XML that was deployed via the grails-activiti plugin is correct, and as I mentioned, work fine with the activiti engine deployed, but they are completely unviewable using the distributed acitiviti webapplications.&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;To make matters stranger, if I deploy the same files via activiti-probe, there is no issue, and I can again use them just fine in the grails webapp via the grails-activiti plugin. Its the other way that there is this failure.&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;My configuration uses the same database instance for both, postgresql in this case. Activiti 5.6 and the XML files were generated via the eclipse designer. The exception suggests some data before the &lt;/SPAN&gt;&lt;BR /&gt;&lt;SPAN&gt;&amp;lt;?xml version="1.0" encoding="UTF-8"?&amp;gt;&lt;/SPAN&gt;&lt;BR /&gt;&lt;SPAN&gt;part of the xml file, but nothing is there… even checked with a hex editor just in case. And, it comes up validate when checking with a validating parser.&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;I'm not sure where to go from here… I've posted a request for help on the grails-activiti plugin side, but I wanted to post here in case someone could direct my attention to where the problem could originate from. &lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;Any ideas?&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;Thanks&lt;/SPAN&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
    <pubDate>Wed, 06 Jul 2011 17:59:20 GMT</pubDate>
    <dc:creator>wolpert</dc:creator>
    <dc:date>2011-07-06T17:59:20Z</dc:date>
    <item>
      <title>Unable to view process definitions via probe: SAXParseExcept</title>
      <link>https://connect.hyland.com/t5/alfresco-archive/unable-to-view-process-definitions-via-probe-saxparseexcept/m-p/77413#M51196</link>
      <description>Folks-&amp;nbsp; I'm using activiti 5.6, via the grails activiti plugin, without a problem. Process definitions are deployed correctly, and can view them correctly via the activiti RepositoryService class. But I get into a problem when I start up the activiti-probe and activiti-explorer webapplication. Attem</description>
      <pubDate>Wed, 06 Jul 2011 17:59:20 GMT</pubDate>
      <guid>https://connect.hyland.com/t5/alfresco-archive/unable-to-view-process-definitions-via-probe-saxparseexcept/m-p/77413#M51196</guid>
      <dc:creator>wolpert</dc:creator>
      <dc:date>2011-07-06T17:59:20Z</dc:date>
    </item>
    <item>
      <title>Re: Unable to view process definitions via probe: SAXParseExcept</title>
      <link>https://connect.hyland.com/t5/alfresco-archive/unable-to-view-process-definitions-via-probe-saxparseexcept/m-p/77414#M51197</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;SPAN&gt;I saw one reference that said if encoding is upper case it could cause this exception. I did change in the files that are generated by the eclipse tool from&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;&amp;lt;?xml version="1.0" encoding="UTF-8"?&amp;gt;&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;to&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;&amp;lt;?xml version="1.0" encoding="utf-8"?&amp;gt;&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;but the error still appears.&amp;nbsp; Still at a loss on this one.&lt;/SPAN&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Wed, 06 Jul 2011 21:56:32 GMT</pubDate>
      <guid>https://connect.hyland.com/t5/alfresco-archive/unable-to-view-process-definitions-via-probe-saxparseexcept/m-p/77414#M51197</guid>
      <dc:creator>wolpert</dc:creator>
      <dc:date>2011-07-06T21:56:32Z</dc:date>
    </item>
    <item>
      <title>Re: Unable to view process definitions via probe: SAXParseExcept</title>
      <link>https://connect.hyland.com/t5/alfresco-archive/unable-to-view-process-definitions-via-probe-saxparseexcept/m-p/77415#M51198</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;SPAN&gt;Does anyone have any insight into this problem?&lt;/SPAN&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Fri, 29 Jul 2011 17:51:08 GMT</pubDate>
      <guid>https://connect.hyland.com/t5/alfresco-archive/unable-to-view-process-definitions-via-probe-saxparseexcept/m-p/77415#M51198</guid>
      <dc:creator>wolpert</dc:creator>
      <dc:date>2011-07-29T17:51:08Z</dc:date>
    </item>
    <item>
      <title>Re: Unable to view process definitions via probe: SAXParseExcept</title>
      <link>https://connect.hyland.com/t5/alfresco-archive/unable-to-view-process-definitions-via-probe-saxparseexcept/m-p/77416#M51199</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;SPAN&gt;The exception happens when there is something wrong as first element.&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;Did you try with a very minimal process? Can you post your process?&lt;/SPAN&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Fri, 05 Aug 2011 13:07:06 GMT</pubDate>
      <guid>https://connect.hyland.com/t5/alfresco-archive/unable-to-view-process-definitions-via-probe-saxparseexcept/m-p/77416#M51199</guid>
      <dc:creator>jbarrez</dc:creator>
      <dc:date>2011-08-05T13:07:06Z</dc:date>
    </item>
    <item>
      <title>Re: Unable to view process definitions via probe: SAXParseExcept</title>
      <link>https://connect.hyland.com/t5/alfresco-archive/unable-to-view-process-definitions-via-probe-saxparseexcept/m-p/77417#M51200</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;SPAN&gt;The issues is independent of the complexity of the activiti xml file to import. &lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;The process definition deployed using probe work fine. Meaning that once deployed, you can view the process definition without the error.&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;If the same XML is deployed using the grails-activiti plugin, reviewing the process fails with the exception show above when trying to review the process with activiti.&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;Correct me if I'm wrong, but probe is retrieving the XML from the core engine using an internal technique, and re-validating what was stored internally. If this is correct, then the part that is delivering the XML to probe is adding something to the XML to cause the error in probe validation of the XML. Remember that using this process defined by the XML does work fine…. so the core engine is working normally. I'm at a loss to explain what occurs during the deployment via grails-activiti that causes this error.&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;I'll come up with specific steps to reproduce this problem, but I'll do it with the next version of activiti (5.7) just in case that impacts the issue.&lt;/SPAN&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Fri, 05 Aug 2011 17:36:18 GMT</pubDate>
      <guid>https://connect.hyland.com/t5/alfresco-archive/unable-to-view-process-definitions-via-probe-saxparseexcept/m-p/77417#M51200</guid>
      <dc:creator>wolpert</dc:creator>
      <dc:date>2011-08-05T17:36:18Z</dc:date>
    </item>
    <item>
      <title>Re: Unable to view process definitions via probe: SAXParseExcept</title>
      <link>https://connect.hyland.com/t5/alfresco-archive/unable-to-view-process-definitions-via-probe-saxparseexcept/m-p/77418#M51201</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;SPAN&gt;Okay, 15 aug is the target date.&lt;/SPAN&gt;&lt;BR /&gt;&lt;SPAN&gt;Keep us posted, as I'm curious to what could lead to the problem.&lt;/SPAN&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Wed, 10 Aug 2011 12:34:58 GMT</pubDate>
      <guid>https://connect.hyland.com/t5/alfresco-archive/unable-to-view-process-definitions-via-probe-saxparseexcept/m-p/77418#M51201</guid>
      <dc:creator>jbarrez</dc:creator>
      <dc:date>2011-08-10T12:34:58Z</dc:date>
    </item>
    <item>
      <title>Re: Unable to view process definitions via probe: SAXParseExcept</title>
      <link>https://connect.hyland.com/t5/alfresco-archive/unable-to-view-process-definitions-via-probe-saxparseexcept/m-p/77419#M51202</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;SPAN&gt;Turns out the problem was resolved at the database driver level. Specifically, the issue is in how the JDBC driver retrieves 'bytea' fields. With the application using 8.4-701 driver against the 9.0 database, the problem would manifest itself in retrieving the data 'in certain cases'. Upgraded to 9.0-801 and it worked fine. Also, the 9.0-801 driver was able to read from the 8.4 database without a problem. (Backwards compatible, not forward compatible, as one would reasonably expect.)&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;I cannot explain why some cases would work and others would not, but since upgrading the JDBC driver fixed all the problem cases, I'm calling it 'good'.&lt;/SPAN&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Tue, 16 Aug 2011 20:16:47 GMT</pubDate>
      <guid>https://connect.hyland.com/t5/alfresco-archive/unable-to-view-process-definitions-via-probe-saxparseexcept/m-p/77419#M51202</guid>
      <dc:creator>wolpert</dc:creator>
      <dc:date>2011-08-16T20:16:47Z</dc:date>
    </item>
    <item>
      <title>Re: Unable to view process definitions via probe: SAXParseExcept</title>
      <link>https://connect.hyland.com/t5/alfresco-archive/unable-to-view-process-definitions-via-probe-saxparseexcept/m-p/77420#M51203</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;SPAN&gt;thanks for reporting back. Appreciated. Can you just add which db it was?&lt;/SPAN&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Wed, 17 Aug 2011 07:21:49 GMT</pubDate>
      <guid>https://connect.hyland.com/t5/alfresco-archive/unable-to-view-process-definitions-via-probe-saxparseexcept/m-p/77420#M51203</guid>
      <dc:creator>ronald_van_kuij</dc:creator>
      <dc:date>2011-08-17T07:21:49Z</dc:date>
    </item>
    <item>
      <title>Re: Unable to view process definitions via probe: SAXParseExcept</title>
      <link>https://connect.hyland.com/t5/alfresco-archive/unable-to-view-process-definitions-via-probe-saxparseexcept/m-p/77421#M51204</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;SPAN&gt;PostgreSQL…&lt;/SPAN&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Thu, 18 Aug 2011 16:08:26 GMT</pubDate>
      <guid>https://connect.hyland.com/t5/alfresco-archive/unable-to-view-process-definitions-via-probe-saxparseexcept/m-p/77421#M51204</guid>
      <dc:creator>wolpert</dc:creator>
      <dc:date>2011-08-18T16:08:26Z</dc:date>
    </item>
    <item>
      <title>Re: Unable to view process definitions via probe: SAXParseExcept</title>
      <link>https://connect.hyland.com/t5/alfresco-archive/unable-to-view-process-definitions-via-probe-saxparseexcept/m-p/77422#M51205</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;SPAN&gt;djeez … that's a very deep bug … kudos that you were able to find it!&lt;/SPAN&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Fri, 26 Aug 2011 08:09:03 GMT</pubDate>
      <guid>https://connect.hyland.com/t5/alfresco-archive/unable-to-view-process-definitions-via-probe-saxparseexcept/m-p/77422#M51205</guid>
      <dc:creator>jbarrez</dc:creator>
      <dc:date>2011-08-26T08:09:03Z</dc:date>
    </item>
  </channel>
</rss>

