<?xml version="1.0" encoding="UTF-8"?>
<rss xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns:taxo="http://purl.org/rss/1.0/modules/taxonomy/" version="2.0">
  <channel>
    <title>topic Re: Alfresco WCM - File Server Deployment Failing - XML Parsing in Alfresco Archive</title>
    <link>https://connect.hyland.com/t5/alfresco-archive/alfresco-wcm-file-server-deployment-failing-xml-parsing/m-p/171720#M124959</link>
    <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;SPAN&gt;Are you running deploy_start.sh in the correct directory or pulling it off a PATH?&lt;/SPAN&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
    <pubDate>Mon, 20 Oct 2008 10:35:00 GMT</pubDate>
    <dc:creator>mrogers</dc:creator>
    <dc:date>2008-10-20T10:35:00Z</dc:date>
    <item>
      <title>Alfresco WCM - File Server Deployment Failing - XML Parsing</title>
      <link>https://connect.hyland.com/t5/alfresco-archive/alfresco-wcm-file-server-deployment-failing-xml-parsing/m-p/171714#M124953</link>
      <description>We're running Alfresco 2.1 Enterprise version with the WCM installed on RedHat Linux Enterprise Edition 5.1 running against an Oracle 10g database.I'd like to get Deployment working using the File System Receiver, but I'm having some issues.Here is my deployment.properties file:dep.datadir=depdatade</description>
      <pubDate>Wed, 19 Mar 2008 20:17:40 GMT</pubDate>
      <guid>https://connect.hyland.com/t5/alfresco-archive/alfresco-wcm-file-server-deployment-failing-xml-parsing/m-p/171714#M124953</guid>
      <dc:creator>bshort</dc:creator>
      <dc:date>2008-03-19T20:17:40Z</dc:date>
    </item>
    <item>
      <title>Re: Alfresco WCM - File Server Deployment Failing - XML Parsing</title>
      <link>https://connect.hyland.com/t5/alfresco-archive/alfresco-wcm-file-server-deployment-failing-xml-parsing/m-p/171715#M124954</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;SPAN&gt;It looks like the problem might be on the two previous lines:&lt;/SPAN&gt;&lt;BR /&gt;&lt;BLOCKQUOTE class="jive-quote"&gt;&amp;lt;bean id="properties" class="org.springframework.beans.factory.config.Prope\&lt;BR /&gt;rtyPlaceholderConfigurer"&amp;gt;&lt;/BLOCKQUOTE&gt;&lt;SPAN&gt;(this needs to be a single line without the '\' character).&amp;nbsp; In fact the DOCTYPE declaration has the same problem too:&lt;/SPAN&gt;&lt;BR /&gt;&lt;BLOCKQUOTE class="jive-quote"&gt;&amp;lt;!DOCTYPE beans PUBLIC '-//SPRING//DTD BEAN//EN' '&lt;A href="http://www.springframework.or\" rel="nofollow noopener noreferrer"&gt;http://www.springframework.or\&lt;/A&gt;&lt;BR /&gt;g/dtd/spring-beans.dtd'&amp;gt;&lt;/BLOCKQUOTE&gt;&lt;SPAN&gt;If that's just an artifact of posting to the forum, let me know and I'll take a closer look at it.&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;Cheers,&lt;/SPAN&gt;&lt;BR /&gt;&lt;SPAN&gt;Peter&lt;/SPAN&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Fri, 21 Mar 2008 03:05:30 GMT</pubDate>
      <guid>https://connect.hyland.com/t5/alfresco-archive/alfresco-wcm-file-server-deployment-failing-xml-parsing/m-p/171715#M124954</guid>
      <dc:creator>pmonks</dc:creator>
      <dc:date>2008-03-21T03:05:30Z</dc:date>
    </item>
    <item>
      <title>Re: Alfresco WCM - File Server Deployment Failing - XML Parsing</title>
      <link>https://connect.hyland.com/t5/alfresco-archive/alfresco-wcm-file-server-deployment-failing-xml-parsing/m-p/171716#M124955</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;SPAN&gt;This is just an artifact of posting in the forum. The linebreaks obviously aren't there in the actual files.&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;I was able to get around some of this by referring to a newer version of java:&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;Here's the new error:&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;PRE class="language-none line-numbers"&gt;&lt;CODE&gt;Mar 21, 2008 3:29:21 PM org.springframework.core.CollectionFactory &amp;lt;clinit&amp;gt;&lt;BR /&gt;INFO: JDK 1.4+ collections available&lt;BR /&gt;Mar 21, 2008 3:29:21 PM org.springframework.beans.factory.xml.XmlBeanDefinitionReader loadBeanDefinitions&lt;BR /&gt;INFO: Loading XML bean definitions from file [/opt/deployment/application-context.xml]&lt;BR /&gt;Mar 21, 2008 3:29:21 PM org.springframework.context.support.AbstractRefreshableApplicationContext refreshBeanFactory&lt;BR /&gt;INFO: Bean factory for application context [org.springframework.context.support.FileSystemXmlApplicationContext;hashCode=3203712]: org.springframework.beans.factory.support.Defau\&lt;BR /&gt;ltListableBeanFactory defining beans [properties,configuration,deploymentReceiverService,deploymentReceiverTransport,deploymentReceiverTransportRMI]; root of BeanFactory hierarch\&lt;BR /&gt;y&lt;BR /&gt;Mar 21, 2008 3:29:21 PM org.springframework.context.support.AbstractApplicationContext refresh&lt;BR /&gt;INFO: 5 beans defined in application context [org.springframework.context.support.FileSystemXmlApplicationContext;hashCode=3203712]&lt;BR /&gt;Mar 21, 2008 3:29:21 PM org.springframework.core.io.support.PropertiesLoaderSupport loadProperties&lt;BR /&gt;INFO: Loading properties file from class path resource [deployment.properties]&lt;BR /&gt;Mar 21, 2008 3:29:21 PM org.springframework.beans.factory.support.DefaultSingletonBeanRegistry destroySingletons&lt;BR /&gt;INFO: Destroying singletons in {org.springframework.beans.factory.support.DefaultListableBeanFactory defining beans [properties,configuration,deploymentReceiverService,deployment\&lt;BR /&gt;ReceiverTransport,deploymentReceiverTransportRMI]; root of BeanFactory hierarchy}&lt;BR /&gt;Exception in thread "main" org.springframework.beans.factory.BeanInitializationException: Could not load properties; nested exception is java.io.FileNotFoundException: class path\&lt;BR /&gt; resource [deployment.properties] cannot be opened because it does not exist&lt;BR /&gt;Caused by: java.io.FileNotFoundException: class path resource [deployment.properties] cannot be opened because it does not exist&lt;BR /&gt;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; at org.springframework.core.io.ClassPathResource.getInputStream(ClassPathResource.java:135)&lt;BR /&gt;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; at org.springframework.core.io.support.PropertiesLoaderSupport.loadProperties(PropertiesLoaderSupport.java:179)&lt;BR /&gt;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; at org.springframework.core.io.support.PropertiesLoaderSupport.mergeProperties(PropertiesLoaderSupport.java:158)&lt;BR /&gt;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; at org.springframework.beans.factory.config.PropertyResourceConfigurer.postProcessBeanFactory(PropertyResourceConfigurer.java:69)&lt;BR /&gt;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; at org.springframework.context.support.AbstractApplicationContext.invokeBeanFactoryPostProcessors(AbstractApplicationContext.java:414)&lt;BR /&gt;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:328)&lt;BR /&gt;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; at org.springframework.context.support.FileSystemXmlApplicationContext.&amp;lt;init&amp;gt;(FileSystemXmlApplicationContext.java:89)&lt;BR /&gt;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; at org.springframework.context.support.FileSystemXmlApplicationContext.&amp;lt;init&amp;gt;(FileSystemXmlApplicationContext.java:74)&lt;BR /&gt;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; at org.springframework.context.support.FileSystemXmlApplicationContext.&amp;lt;init&amp;gt;(FileSystemXmlApplicationContext.java:65)&lt;BR /&gt;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp;&amp;nbsp; at org.alfresco.deployment.Main.main(Main.java:47)&lt;BR /&gt;&lt;SPAN class="line-numbers-rows"&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;/SPAN&gt;&lt;/CODE&gt;&lt;/PRE&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Fri, 21 Mar 2008 19:45:45 GMT</pubDate>
      <guid>https://connect.hyland.com/t5/alfresco-archive/alfresco-wcm-file-server-deployment-failing-xml-parsing/m-p/171716#M124955</guid>
      <dc:creator>bshort</dc:creator>
      <dc:date>2008-03-21T19:45:45Z</dc:date>
    </item>
    <item>
      <title>Re: Alfresco WCM - File Server Deployment Failing - XML Parsing</title>
      <link>https://connect.hyland.com/t5/alfresco-archive/alfresco-wcm-file-server-deployment-failing-xml-parsing/m-p/171717#M124956</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;SPAN&gt;This latest exception indicates that Spring is unable to find the "deployment.properties" file in the classpath.&amp;nbsp; Are you starting the FileSystem Receiver using the "deploy_start.sh" command, or manually?&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;Either way, it's critical that the directory the FSR is installed into is in the classpath.&amp;nbsp; The best way to do this (which is used by the "deploy_start.sh" script as of 2.2 - not sure about earlier versions) is to use the following JVM startup parameter:&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;PRE class="language-none line-numbers"&gt;&lt;CODE&gt;-Djava.ext.dirs=[directory in which FSR is installed]&lt;SPAN class="line-numbers-rows"&gt;&lt;SPAN&gt;‍&lt;/SPAN&gt;&lt;/SPAN&gt;&lt;/CODE&gt;&lt;/PRE&gt;&lt;SPAN&gt;Cheers,&lt;/SPAN&gt;&lt;BR /&gt;&lt;SPAN&gt;Peter&lt;/SPAN&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Fri, 21 Mar 2008 20:04:35 GMT</pubDate>
      <guid>https://connect.hyland.com/t5/alfresco-archive/alfresco-wcm-file-server-deployment-failing-xml-parsing/m-p/171717#M124956</guid>
      <dc:creator>pmonks</dc:creator>
      <dc:date>2008-03-21T20:04:35Z</dc:date>
    </item>
    <item>
      <title>Re: Alfresco WCM - File Server Deployment Failing - XML Parsing</title>
      <link>https://connect.hyland.com/t5/alfresco-archive/alfresco-wcm-file-server-deployment-failing-xml-parsing/m-p/171718#M124957</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;SPAN&gt;Peter that seemed to work!&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;Thank you for your help,&lt;/SPAN&gt;&lt;BR /&gt;&lt;SPAN&gt;-Brian&lt;/SPAN&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Fri, 21 Mar 2008 21:59:57 GMT</pubDate>
      <guid>https://connect.hyland.com/t5/alfresco-archive/alfresco-wcm-file-server-deployment-failing-xml-parsing/m-p/171718#M124957</guid>
      <dc:creator>bshort</dc:creator>
      <dc:date>2008-03-21T21:59:57Z</dc:date>
    </item>
    <item>
      <title>Re: Alfresco WCM - File Server Deployment Failing - XML Parsing</title>
      <link>https://connect.hyland.com/t5/alfresco-archive/alfresco-wcm-file-server-deployment-failing-xml-parsing/m-p/171719#M124958</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;SPAN&gt;Hi,&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;I am getting the same error with FSR v2.2? &lt;/SPAN&gt;&lt;BR /&gt;&lt;SPAN&gt;I have checked the deploy_start.sh script and the classpath parameter is being set "-Djava.ext.dirs=."&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;Any ideas?&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;Thanks, James.&lt;/SPAN&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Mon, 20 Oct 2008 09:57:36 GMT</pubDate>
      <guid>https://connect.hyland.com/t5/alfresco-archive/alfresco-wcm-file-server-deployment-failing-xml-parsing/m-p/171719#M124958</guid>
      <dc:creator>jameskinley</dc:creator>
      <dc:date>2008-10-20T09:57:36Z</dc:date>
    </item>
    <item>
      <title>Re: Alfresco WCM - File Server Deployment Failing - XML Parsing</title>
      <link>https://connect.hyland.com/t5/alfresco-archive/alfresco-wcm-file-server-deployment-failing-xml-parsing/m-p/171720#M124959</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;SPAN&gt;Are you running deploy_start.sh in the correct directory or pulling it off a PATH?&lt;/SPAN&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Mon, 20 Oct 2008 10:35:00 GMT</pubDate>
      <guid>https://connect.hyland.com/t5/alfresco-archive/alfresco-wcm-file-server-deployment-failing-xml-parsing/m-p/171720#M124959</guid>
      <dc:creator>mrogers</dc:creator>
      <dc:date>2008-10-20T10:35:00Z</dc:date>
    </item>
    <item>
      <title>Re: Alfresco WCM - File Server Deployment Failing - XML Parsing</title>
      <link>https://connect.hyland.com/t5/alfresco-archive/alfresco-wcm-file-server-deployment-failing-xml-parsing/m-p/171721#M124960</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;SPAN&gt;I'm running deploy_start.sh from within the "/opt/Alfresco/Deployment" directory (the default install location).&lt;/SPAN&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Mon, 20 Oct 2008 11:02:30 GMT</pubDate>
      <guid>https://connect.hyland.com/t5/alfresco-archive/alfresco-wcm-file-server-deployment-failing-xml-parsing/m-p/171721#M124960</guid>
      <dc:creator>jameskinley</dc:creator>
      <dc:date>2008-10-20T11:02:30Z</dc:date>
    </item>
    <item>
      <title>Re: Alfresco WCM - File Server Deployment Failing - XML Parsing</title>
      <link>https://connect.hyland.com/t5/alfresco-archive/alfresco-wcm-file-server-deployment-failing-xml-parsing/m-p/171722#M124961</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;SPAN&gt;Is there a deployment.properties file in /opt/Alfresco/Deployment?&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;Cheers,&lt;/SPAN&gt;&lt;BR /&gt;&lt;SPAN&gt;Peter&lt;/SPAN&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Mon, 20 Oct 2008 20:00:36 GMT</pubDate>
      <guid>https://connect.hyland.com/t5/alfresco-archive/alfresco-wcm-file-server-deployment-failing-xml-parsing/m-p/171722#M124961</guid>
      <dc:creator>pmonks</dc:creator>
      <dc:date>2008-10-20T20:00:36Z</dc:date>
    </item>
    <item>
      <title>Re: Alfresco WCM - File Server Deployment Failing - XML Parsing</title>
      <link>https://connect.hyland.com/t5/alfresco-archive/alfresco-wcm-file-server-deployment-failing-xml-parsing/m-p/171723#M124962</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;SPAN&gt;Can anybody post the sample deploy_start.sh&lt;/SPAN&gt;&lt;BR /&gt;&lt;SPAN&gt; &lt;/SPAN&gt;&lt;BR /&gt;&lt;SPAN&gt;I want to configure it correctly. showing the same error logs. But unable to configure deployment.properties&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;Thanks!&lt;/SPAN&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Mon, 19 Jan 2009 10:21:12 GMT</pubDate>
      <guid>https://connect.hyland.com/t5/alfresco-archive/alfresco-wcm-file-server-deployment-failing-xml-parsing/m-p/171723#M124962</guid>
      <dc:creator>pawanawaits</dc:creator>
      <dc:date>2009-01-19T10:21:12Z</dc:date>
    </item>
  </channel>
</rss>

