<?xml version="1.0" encoding="UTF-8"?>
<rss xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns:taxo="http://purl.org/rss/1.0/modules/taxonomy/" version="2.0">
  <channel>
    <title>topic Re: Installation Errors w/ SQL Server in Alfresco Archive</title>
    <link>https://connect.hyland.com/t5/alfresco-archive/installation-errors-w-sql-server/m-p/24896#M12234</link>
    <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;SPAN&gt;I noticed the followling line in the stack trace:&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;STRONG&gt;Caused by: org.alfresco.repo.search.SearcherException: More than one root node in index: 2 &lt;/STRONG&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;This usually indicates that you have more than one set of index files or they are not in sync with the database.&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;The best thing to do is point the alf_data directory outside the bundle (rather than the relative path it has by default).&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;In your repository.properties file you should also have something like:&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;dir.root=c:\alf_data&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;See the repository configuration wiki page for more info: &lt;/SPAN&gt;&lt;A href="http://www.alfresco.org/mediawiki/index.php/Repository_Configuration" rel="nofollow noopener noreferrer"&gt;http://www.alfresco.org/mediawiki/index.php/Repository_Configuration&lt;/A&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
    <pubDate>Wed, 01 Mar 2006 09:15:08 GMT</pubDate>
    <dc:creator>gavinc</dc:creator>
    <dc:date>2006-03-01T09:15:08Z</dc:date>
    <item>
      <title>Installation Errors w/ SQL Server</title>
      <link>https://connect.hyland.com/t5/alfresco-archive/installation-errors-w-sql-server/m-p/24895#M12233</link>
      <description>Hi, I'm hoping someone can help me…I verify that it connects and creates the tables on the database, but it won't start the Alfresco service.Here's my hibernate-cfg.properties:[size=75]## Hibernate configuration#hibernate.jdbc.use_streams_for_binary=truehibernate.dialect=org.hibernate.dialect.SQLSer</description>
      <pubDate>Wed, 01 Mar 2006 05:32:50 GMT</pubDate>
      <guid>https://connect.hyland.com/t5/alfresco-archive/installation-errors-w-sql-server/m-p/24895#M12233</guid>
      <dc:creator>doug</dc:creator>
      <dc:date>2006-03-01T05:32:50Z</dc:date>
    </item>
    <item>
      <title>Re: Installation Errors w/ SQL Server</title>
      <link>https://connect.hyland.com/t5/alfresco-archive/installation-errors-w-sql-server/m-p/24896#M12234</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;SPAN&gt;I noticed the followling line in the stack trace:&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;STRONG&gt;Caused by: org.alfresco.repo.search.SearcherException: More than one root node in index: 2 &lt;/STRONG&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;This usually indicates that you have more than one set of index files or they are not in sync with the database.&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;The best thing to do is point the alf_data directory outside the bundle (rather than the relative path it has by default).&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;In your repository.properties file you should also have something like:&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;dir.root=c:\alf_data&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;See the repository configuration wiki page for more info: &lt;/SPAN&gt;&lt;A href="http://www.alfresco.org/mediawiki/index.php/Repository_Configuration" rel="nofollow noopener noreferrer"&gt;http://www.alfresco.org/mediawiki/index.php/Repository_Configuration&lt;/A&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Wed, 01 Mar 2006 09:15:08 GMT</pubDate>
      <guid>https://connect.hyland.com/t5/alfresco-archive/installation-errors-w-sql-server/m-p/24896#M12234</guid>
      <dc:creator>gavinc</dc:creator>
      <dc:date>2006-03-01T09:15:08Z</dc:date>
    </item>
    <item>
      <title>Re: Installation Errors w/ SQL Server</title>
      <link>https://connect.hyland.com/t5/alfresco-archive/installation-errors-w-sql-server/m-p/24897#M12235</link>
      <description>&lt;HTML&gt;&lt;HEAD&gt;&lt;/HEAD&gt;&lt;BODY&gt;&lt;SPAN&gt;Thanks gavinc, that did it! I was working on migrating from mysql to mssql. In fact, I've even got this to work with sql 2005 now. &lt;img id="smileyhappy" class="emoticon emoticon-smileyhappy" src="https://connect.hyland.com/i/smilies/16x16_smiley-happy.png" alt="Smiley Happy" title="Smiley Happy" /&gt; Only with the jDTS driver. The ms jdbc driver for 2005 doesn't work, I think it has to do with hibernate support.&lt;/SPAN&gt;&lt;BR /&gt;&lt;BR /&gt;&lt;SPAN&gt;Thanks for the rapid response and a correct response that provided the resolution!!! &lt;img id="smileyhappy" class="emoticon emoticon-smileyhappy" src="https://connect.hyland.com/i/smilies/16x16_smiley-happy.png" alt="Smiley Happy" title="Smiley Happy" /&gt;&lt;/SPAN&gt;&lt;/BODY&gt;&lt;/HTML&gt;</description>
      <pubDate>Thu, 02 Mar 2006 01:57:24 GMT</pubDate>
      <guid>https://connect.hyland.com/t5/alfresco-archive/installation-errors-w-sql-server/m-p/24897#M12235</guid>
      <dc:creator>doug</dc:creator>
      <dc:date>2006-03-02T01:57:24Z</dc:date>
    </item>
  </channel>
</rss>

